$re = '/(\w([.-]?))+\@\w+\.\w+/';
$str = 'valid:
benji_yang@basic.cn
benji.yang@roolbox.com
benji-yang@gmail.org
invalid:
@gmail.com
1@.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);