import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w([.-]?))+\\@\\w+\\.\\w+";
final String string = "valid:\n"
+ "benji_yang@basic.cn\n"
+ "benji.yang@roolbox.com\n"
+ "benji-yang@gmail.org\n\n"
+ "invalid:\n"
+ "@gmail.com\n"
+ "1@.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}