const regex = /(\w([.-]?))+\@\w+\.\w+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w([.-]?))+\\@\\w+\\.\\w+', 'g')
const str = `valid:
benji_yang@basic.cn
benji.yang@roolbox.com
benji-yang@gmail.org
invalid:
@gmail.com
1@.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}