import Foundation
let pattern = #"(?:lazy_)?ngtxt\(([\"\'])((?:(?!\1)[^\\]|\\.)+)\1,\s*([\"\'])((?:(?!\3)[^\\]|\\.)+)\3,\s*(?:.+?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
* ngtxt('i am in single-quotes', 'i am in single-quotes 2', foo)
* ngtxt('i have \' an escaped single-quote within single-quotes', 'i have \' an escaped single-quote within single-quotes 2', foo)
* ngtxt('i have a "double-quote" in single-quotes', 'i have a "double-quote" in single-quotes 2', foo)
* ngtxt("i am in double-quotes", "i am in double-quotes 2", foo)
* ngtxt("i am in double-quotes with single 'quotes'", "i am in double-quotes with single 'quotes' 2", foo)
* ngtxt('i have an escaped double-quote \" within double-quotes', 'i have an escaped double-quote \" within double-quotes 2', foo)
* ngtxt('i am singular in single-quotes', "i am plural in double-quotes", foo)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)