# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:lazy_)?ngtxt\(([\"\'])((?:(?!\1)[^\\]|\\.)+)\1,\s*([\"\'])((?:(?!\3)[^\\]|\\.)+)\3,\s*(?:.+?)\)"
test_str = ("* ngtxt('i am in single-quotes', 'i am in single-quotes 2', foo)\n"
"* ngtxt('i have \\' an escaped single-quote within single-quotes', 'i have \\' an escaped single-quote within single-quotes 2', foo)\n"
"* ngtxt('i have a \"double-quote\" in single-quotes', 'i have a \"double-quote\" in single-quotes 2', foo)\n"
"* ngtxt(\"i am in double-quotes\", \"i am in double-quotes 2\", foo)\n"
"* ngtxt(\"i am in double-quotes with single 'quotes'\", \"i am in double-quotes with single 'quotes' 2\", foo)\n"
"* ngtxt('i have an escaped double-quote \\\" within double-quotes', 'i have an escaped double-quote \\\" within double-quotes 2', foo)\n"
"* ngtxt('i am singular in single-quotes', \"i am plural in double-quotes\", foo)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.