#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:lazy_)?ngtxt\(([\"\'])((?:(?!\1)[^\\]|\\.)+)\1,\s*([\"\'])((?:(?!\3)[^\\]|\\.)+)\3,\s*(?:.+?)\)"
Local $sString = "* ngtxt('i am in single-quotes', 'i am in single-quotes 2', foo)" & @CRLF & _
"* ngtxt('i have \' an escaped single-quote within single-quotes', 'i have \' an escaped single-quote within single-quotes 2', foo)" & @CRLF & _
"* ngtxt('i have a "double-quote" in single-quotes', 'i have a "double-quote" in single-quotes 2', foo)" & @CRLF & _
"* ngtxt("i am in double-quotes", "i am in double-quotes 2", foo)" & @CRLF & _
"* ngtxt("i am in double-quotes with single 'quotes'", "i am in double-quotes with single 'quotes' 2", foo)" & @CRLF & _
"* ngtxt('i have an escaped double-quote \" within double-quotes', 'i have an escaped double-quote \" within double-quotes 2', foo)" & @CRLF & _
"* ngtxt('i am singular in single-quotes', "i am plural in double-quotes", foo)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")