import Foundation
let pattern = #"^@import\s+(?:url\(['"]?.*?['"]?\)|['"].*?['"])(\s+[^;]+?)?;$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;
@import url("https://clearvision.github.io/ClearVision-v6/main.css") asd;
@import 'https://clearvision.github.io/ClearVision-v6/main.css' asd;
@import url("landscape.css") screen and (orientation: landscape);
@import "landscape.css" screen and (orientation: landscape);
@import url("flexy.css") supports(not (display: grid) and (display: flex)) screen
and (max-width: 400px);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)