use strict;
my $str = '@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;
@import url("https://clearvision.github.io/ClearVision-v6/main.css") asd;
@import \'https://clearvision.github.io/ClearVision-v6/main.css\' asd;
@import url("landscape.css") screen and (orientation: landscape);
@import "landscape.css" screen and (orientation: landscape);
@import url("flexy.css") supports(not (display: grid) and (display: flex)) screen
and (max-width: 400px);';
my $regex = qr/^@import\s+(?:url\(['"]?.*?['"]?\)|['"].*?['"])(\s+[^;]+?)?;$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}