using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@import\s+(?:url\(['""]?.*?['""]?\)|['""].*?['""])(\s+[^;]+?)?;$";
string input = @"@import url(https://clearvision.github.io/ClearVision-v6/main.css) asd;
@import url(""https://clearvision.github.io/ClearVision-v6/main.css"") asd;
@import 'https://clearvision.github.io/ClearVision-v6/main.css' asd;
@import url(""landscape.css"") screen and (orientation: landscape);
@import ""landscape.css"" screen and (orientation: landscape);
@import url(""flexy.css"") supports(not (display: grid) and (display: flex)) screen
and (max-width: 400px);";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}