use strict;
my $str = '", "/api/bike/portal/available/hours", "/api/bike/portal/business/status", "/api/bike/portal/earnings/aggregate", "/api/bike/portal/roles/profile"],
.//2022101152_16.b89695434a4e47b29104.js:4402: return this.httpClient.get("/api/bike/portal/lastseens/bikecompany/" + l)
.//2022101152_16.b89695434a4e47b29104.js:4407: }).join(","))), e.length && (t = t.set("businessStatus", e.join(","))), this.httpClient.get("/api/bike/portal/bikeCompany/" + l + "/businesss/lastseens", {
.//2022101152_16.b89695434a4e47b29104.js:4411: return this.httpClient.get("/api/bike/portal/" + l + "/metadata/dcts")
.//2022101152_16.b89695434a4e47b29104.js:6299: return this.httpClient.post("/api/bike/portal/switching/business/noc/accept", {
this.httpClient.get("/api/bike/portal/" + l + "/" + n + "/profile")
post("/api/bike/portal/" + l + "/email/verification/response", {
.get("/api/bike/portal/" + l + "/invoices")
.//2022101152_16.b89695434a4e47b29104.js:6709: return this.httpClient.delete("/api/bike/portal/" + l + "/invoices/" + n + "/download-link", {
.//2022101152_16.b89695434a4e47b29104.js:7357: return this.httpClient.put("/api/bike/portal/earnings/cycles/" + l + "/partial", {
.//2022101152_16.b89695434a4e47b29104.js:7362: return this.httpClient.head("/api/bike/portal/business/acceptance/" + l, {
.//2022101152_16.b89695434a4e47b29104.js:7367: return this.httpClient.options("/api/bike/portal/available/hours/" + l, {';
my $regex = qr/\.(?>post|put|get|patch|delete|head|options)\((?>[\"\']?)(\/?api(?>\/\w+){0,}\/?)\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}