using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?>post|put|get|patch|delete|head|options)\((?>[\""\']?)(\/?api(?>\/\w+){0,}\/?)\w+";
string input = @""", ""/api/bike/portal/available/hours"", ""/api/bike/portal/business/status"", ""/api/bike/portal/earnings/aggregate"", ""/api/bike/portal/roles/profile""],
.//2022101152_16.b89695434a4e47b29104.js:4402: return this.httpClient.get(""/api/bike/portal/lastseens/bikecompany/"" + l)
.//2022101152_16.b89695434a4e47b29104.js:4407: }).join("",""))), e.length && (t = t.set(""businessStatus"", e.join("",""))), this.httpClient.get(""/api/bike/portal/bikeCompany/"" + l + ""/businesss/lastseens"", {
.//2022101152_16.b89695434a4e47b29104.js:4411: return this.httpClient.get(""/api/bike/portal/"" + l + ""/metadata/dcts"")
.//2022101152_16.b89695434a4e47b29104.js:6299: return this.httpClient.post(""/api/bike/portal/switching/business/noc/accept"", {
this.httpClient.get(""/api/bike/portal/"" + l + ""/"" + n + ""/profile"")
post(""/api/bike/portal/"" + l + ""/email/verification/response"", {
.get(""/api/bike/portal/"" + l + ""/invoices"")
.//2022101152_16.b89695434a4e47b29104.js:6709: return this.httpClient.delete(""/api/bike/portal/"" + l + ""/invoices/"" + n + ""/download-link"", {
.//2022101152_16.b89695434a4e47b29104.js:7357: return this.httpClient.put(""/api/bike/portal/earnings/cycles/"" + l + ""/partial"", {
.//2022101152_16.b89695434a4e47b29104.js:7362: return this.httpClient.head(""/api/bike/portal/business/acceptance/"" + l, {
.//2022101152_16.b89695434a4e47b29104.js:7367: return this.httpClient.options(""/api/bike/portal/available/hours/"" + l, {";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}