#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(?>post|put|get|patch|delete|head|options)\((?>[\"\']?)(\/?api(?>\/\w+){0,}\/?)\w+"
Local $sString = "", "/api/bike/portal/available/hours", "/api/bike/portal/business/status", "/api/bike/portal/earnings/aggregate", "/api/bike/portal/roles/profile"]," & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:4402: return this.httpClient.get("/api/bike/portal/lastseens/bikecompany/" + l)" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:4407: }).join(","))), e.length && (t = t.set("businessStatus", e.join(","))), this.httpClient.get("/api/bike/portal/bikeCompany/" + l + "/businesss/lastseens", {" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:4411: return this.httpClient.get("/api/bike/portal/" + l + "/metadata/dcts")" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:6299: return this.httpClient.post("/api/bike/portal/switching/business/noc/accept", {" & @CRLF & _
"this.httpClient.get("/api/bike/portal/" + l + "/" + n + "/profile")" & @CRLF & _
"post("/api/bike/portal/" + l + "/email/verification/response", {" & @CRLF & _
".get("/api/bike/portal/" + l + "/invoices")" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:6709: return this.httpClient.delete("/api/bike/portal/" + l + "/invoices/" + n + "/download-link", {" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:7357: return this.httpClient.put("/api/bike/portal/earnings/cycles/" + l + "/partial", {" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:7362: return this.httpClient.head("/api/bike/portal/business/acceptance/" + l, {" & @CRLF & _
".//2022101152_16.b89695434a4e47b29104.js:7367: return this.httpClient.options("/api/bike/portal/available/hours/" + l, {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")