// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http(?:s)?\:\/\/boards\.(4chan|4channel)\.org\/([a-z]*)\/thread\/([0-9]*)(?:\#[0-9a-z]*)?").unwrap();
let string = "https://boards.4chan.org/mlp/thread/5
http://boards.4chan.org/b/thread/570277846
https://boards.4chan.org/mlp/thread/19865655#q19865655
https://boards.4chan.org/mlp/thread/19775771
https://boards.4chan.org/co/thread/65737750#q65737750
https://boards.4channel.org/a/thread/241489992";
let substitution = "Thread $3 on $2 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}