use strict;
my $str = 'https://boards.4chan.org/mlp/thread/5
http://boards.4chan.org/b/thread/570277846
https://boards.4chan.org/mlp/thread/19865655#q19865655
https://boards.4chan.org/mlp/thread/19775771
https://boards.4chan.org/co/thread/65737750#q65737750
https://boards.4channel.org/a/thread/241489992';
my $regex = qr/http(?:s)?\:\/\/boards\.(4chan|4channel)\.org\/([a-z]*)\/thread\/([0-9]*)(?:\#[0-9a-z]*)?/p;
my $subst = 'Thread $3 on $2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";