re = /(?<text>.*)(?<newline>[\r\n]+)/m
str = 'abcdef
ghijkl
mnrstu
vwxyz
'
subst = '${text}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result