$re = '/(?<text>.*)(?<newline>[\r\n]+)/m';
$str = 'abcdef
ghijkl
mnrstu
vwxyz
';
$subst = "${text}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;