use strict;
my $str = 'abcdef
ghijkl
mnrstu
vwxyz
';
my $regex = qr/(?<text>.*)(?<newline>[\r\n]+)/mp;
my $subst = '${text}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";