re = /<([a-z]+)(?>"[^"]*"|'[^']*'|[^\/>])*(?>>(?>(?R)|[\s\S])*?<\/\1>|\/?>)/
str = '<asdf>asdf</asdf>
<asdf />
<asdf asdf="asdf>asdf">asdf</asdf>
<asdf>
<asdf>asdf</asdf>
<asdf>asdf</asdf>
<asdf>
<asdf />
<asdf />
asdf
</asdf>
<asdf asdf="asdf<asdf>">asdf</asdf>
</asdf>
<asdf asdf="asdf>asdf" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end