#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([a-z]+)(?>"[^"]*"|'[^']*'|[^\/>])*(?>>(?>(?R)|[\s\S])*?<\/\1>|\/?>)"
Local $sString = "<asdf>asdf</asdf>" & @CRLF & _
"" & @CRLF & _
"<asdf />" & @CRLF & _
"" & @CRLF & _
"<asdf asdf="asdf>asdf">asdf</asdf>" & @CRLF & _
"" & @CRLF & _
"<asdf>" & @CRLF & _
" <asdf>asdf</asdf>" & @CRLF & _
" <asdf>asdf</asdf>" & @CRLF & _
" <asdf>" & @CRLF & _
" <asdf />" & @CRLF & _
" <asdf />" & @CRLF & _
" asdf" & @CRLF & _
" </asdf>" & @CRLF & _
" <asdf asdf="asdf<asdf>">asdf</asdf>" & @CRLF & _
"</asdf>" & @CRLF & _
"" & @CRLF & _
"<asdf asdf="asdf>asdf" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")