import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z]+)(?>\"[^\"]*\"|'[^']*'|[^\\/>])*(?>>(?>(?R)|[\\s\\S])*?<\\/\\1>|\\/?>)";
final String string = "<asdf>asdf</asdf>\n\n"
+ "<asdf />\n\n"
+ "<asdf asdf=\"asdf>asdf\">asdf</asdf>\n\n"
+ "<asdf>\n"
+ " <asdf>asdf</asdf>\n"
+ " <asdf>asdf</asdf>\n"
+ " <asdf>\n"
+ " <asdf />\n"
+ " <asdf />\n"
+ " asdf\n"
+ " </asdf>\n"
+ " <asdf asdf=\"asdf<asdf>\">asdf</asdf>\n"
+ "</asdf>\n\n"
+ "<asdf asdf=\"asdf>asdf\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}