$re = '/^(Mr|Mrs|Ms|Dr|Er)(\.)([a-zA-Z])+$/';
$str = 'Mrs.Y';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);