package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(Mr|Mrs|Ms|Dr|Er)(\.)([a-zA-Z])+$`)
var str = `Mrs.Y`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}