using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Mr|Mrs|Ms|Dr|Er)(\.)([a-zA-Z])+$";
string input = @"Mrs.Y";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}