re = /\s/m
str = 'Comment optimiser vos performances athlétiques avec notre gel arnica au CBD'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result