package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s`)
var str = `Comment optimiser vos performances athlétiques avec notre gel arnica au CBD`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}