$re = '/\s/m';
$str = 'Comment optimiser vos performances athlétiques avec notre gel arnica au CBD';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;