re = /(\/[\D]{2}-((?!us).){2}\/)/m
str = '/advanced_search_result.php
/shopping_cart.php
/create_account.php
/index.php
/wetsuits-cx-1.html
/not_found.php
/womens-wetsuits-cx-15.html
/checkout_confirmation.php
/checkout_payment.php
/mens-wetsuits-cx-14.html
/womens-c-47_65.html
/sv-se/index.php
/de-ch/2020-helly-hansen-50n-rider-vest-buoyancy-aid-33820-red-p-11170.html
/sale/index.php
/fi-fi/index.php
/en-dk/index.php
/nl-be/index.php
/no-no/index.php
/es-us/index.php
watersportsoutlet.com/es-us/index.php
www.watersportsoutlet.com/es-us/index.php
watersportsoutlet.com/no-no/index.php
www.watersportsoutlet.com/no-no/index.php
/ext/modules/payment/paypal/checkout.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end