import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/[\\D]{2}-((?!us).){2}\\/)";
final String string = "/advanced_search_result.php\n"
+ "/shopping_cart.php\n"
+ "/create_account.php\n"
+ "/index.php\n"
+ "/wetsuits-cx-1.html\n"
+ "/not_found.php\n"
+ "/womens-wetsuits-cx-15.html\n"
+ "/checkout_confirmation.php\n"
+ "/checkout_payment.php\n"
+ "/mens-wetsuits-cx-14.html\n"
+ "/womens-c-47_65.html\n"
+ "/sv-se/index.php\n"
+ "/de-ch/2020-helly-hansen-50n-rider-vest-buoyancy-aid-33820-red-p-11170.html\n"
+ "/sale/index.php\n"
+ "/fi-fi/index.php\n"
+ "/en-dk/index.php\n"
+ "/nl-be/index.php\n"
+ "/no-no/index.php\n"
+ "/es-us/index.php\n"
+ "watersportsoutlet.com/es-us/index.php\n"
+ "www.watersportsoutlet.com/es-us/index.php\n"
+ "watersportsoutlet.com/no-no/index.php\n"
+ "www.watersportsoutlet.com/no-no/index.php\n"
+ "/ext/modules/payment/paypal/checkout.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}