#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/[\D]{2}-((?!us).){2}\/)"
Local $sString = "/advanced_search_result.php" & @CRLF & _
"/shopping_cart.php" & @CRLF & _
"/create_account.php" & @CRLF & _
"/index.php" & @CRLF & _
"/wetsuits-cx-1.html" & @CRLF & _
"/not_found.php" & @CRLF & _
"/womens-wetsuits-cx-15.html" & @CRLF & _
"/checkout_confirmation.php" & @CRLF & _
"/checkout_payment.php" & @CRLF & _
"/mens-wetsuits-cx-14.html" & @CRLF & _
"/womens-c-47_65.html" & @CRLF & _
"/sv-se/index.php" & @CRLF & _
"/de-ch/2020-helly-hansen-50n-rider-vest-buoyancy-aid-33820-red-p-11170.html" & @CRLF & _
"/sale/index.php" & @CRLF & _
"/fi-fi/index.php" & @CRLF & _
"/en-dk/index.php" & @CRLF & _
"/nl-be/index.php" & @CRLF & _
"/no-no/index.php" & @CRLF & _
"/es-us/index.php" & @CRLF & _
"watersportsoutlet.com/es-us/index.php" & @CRLF & _
"www.watersportsoutlet.com/es-us/index.php" & @CRLF & _
"watersportsoutlet.com/no-no/index.php" & @CRLF & _
"www.watersportsoutlet.com/no-no/index.php" & @CRLF & _
"/ext/modules/payment/paypal/checkout.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")