re = /nz\.co\.trimble\.((?!bsg).*).*/m
str = 'nz.co.trimble.bsg.core
nz.co.trimble.core
nz.co.trimble.vwservices
nz.co.trimble.bsg.vwservices'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end