$re = '/nz\.co\.trimble\.((?!bsg).*).*/m';
$str = 'nz.co.trimble.bsg.core
nz.co.trimble.core
nz.co.trimble.vwservices
nz.co.trimble.bsg.vwservices';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);