using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"nz\.co\.trimble\.((?!bsg).*).*";
string input = @"nz.co.trimble.bsg.core
nz.co.trimble.core
nz.co.trimble.vwservices
nz.co.trimble.bsg.vwservices";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}