import Foundation
let pattern = #"^(c\/|calle|carrer)?\W?(\w+\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*(?<!num))\W(nº|num|núm|num\.|núm\.|numero|número|n|n\.|no|no\.)?\W?(\d{1,3}\-?\d{1,3}?)\W?(bis|dup|mod|ant)?\W+(BJ)?\W\w+\W"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
calle Monistrol de la vega num 13-15, BJ1 08012 Barcelona
calle Monistrol 13, BJ1 08012 Barcelona
carrer Monistrol 13, BJ1 08012 Barcelona
Monistrol 13, BJ1 08012 Barcelona
c/ Monistrol, 13, BJ1 08012 Barcelona
calle Monistrol nº 13, BJ1 08012 Barcelona
calle Monistrol 13, bajo 1 08012 Barcelona
c/ Monistrol 13, Bajo 1º, 08012 Barcelona
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)