$re = '/^(c\/|calle|carrer)?\W?(\w+\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*\W?[A-z]*(?<!num))\W(nº|num|núm|num\.|núm\.|numero|número|n|n\.|no|no\.)?\W?(\d{1,3}\-?\d{1,3}?)\W?(bis|dup|mod|ant)?\W+(BJ)?\W\w+\W/i';
$str = 'calle Monistrol de la vega num 13-15, BJ1 08012 Barcelona
calle Monistrol 13, BJ1 08012 Barcelona
carrer Monistrol 13, BJ1 08012 Barcelona
Monistrol 13, BJ1 08012 Barcelona
c/ Monistrol, 13, BJ1 08012 Barcelona
calle Monistrol nº 13, BJ1 08012 Barcelona
calle Monistrol 13, bajo 1 08012 Barcelona
c/ Monistrol 13, Bajo 1º, 08012 Barcelona
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);