import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(c\\/|calle|carrer)?\\W?(\\w+\\W?[A-z]*\\W?[A-z]*\\W?[A-z]*\\W?[A-z]*\\W?[A-z]*\\W?[A-z]*(?<!num))\\W(nº|num|núm|num\\.|núm\\.|numero|número|n|n\\.|no|no\\.)?\\W?(\\d{1,3}\\-?\\d{1,3}?)\\W?(bis|dup|mod|ant)?\\W+(BJ)?\\W\\w+\\W";
final String string = "calle Monistrol de la vega num 13-15, BJ1 08012 Barcelona \n"
+ "calle Monistrol 13, BJ1 08012 Barcelona\n"
+ "carrer Monistrol 13, BJ1 08012 Barcelona\n"
+ "Monistrol 13, BJ1 08012 Barcelona\n"
+ "c/ Monistrol, 13, BJ1 08012 Barcelona\n"
+ "calle Monistrol nº 13, BJ1 08012 Barcelona\n"
+ "calle Monistrol 13, bajo 1 08012 Barcelona\n"
+ "c/ Monistrol 13, Bajo 1º, 08012 Barcelona\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}