# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((2[0-4]\d|25[0-5]|1\d\d|0\d\d|0\d|\d\d|\d)[\.]){3}(2[0-4]\d|25[0-5]|1\d\d|0\d\d|0\d|\d\d|\d)|(((\w*)://(www)*)\.*((\w*-*\w*)\.)*(\w*)(:\d+)*/*#*(/*)(\w+/)*(\w*\$*\w*\,*\w*\?*=*)*\.*(\w*))|((www\.)*(\w+-*)(\.\w+)+)(:\d+)*/*#*(/*)(\w+/)*(\w*\$*\w*\,*\w*\?*=*)*\.*(\w*)"
test_str = ("hxxp://securedownload2.duckdns.org:7373/docs/ @JAMESWT_MHT\n"
"abc://www.hhghg.ghgh.jkjkjk.jkjkj.jkjk\n"
"#LokiBot @ hxxp://xupfile.duckdns.org:1133/$59,200.exe \n"
"https://www.reverse.it/sample/529b10d3faaa143c074d0f25ee75c8e9bad7f5982ead482d6c0c19a39d207b68?environmentId=100 …\n"
"1.2.3.4\n"
"www.virustotal.com\n"
"C2: hta.duckdns.org:7373/excel/fre.php\n"
"http://www.virustotal.com/en/file/a94f7db23f64985f22a4250886db0d67e3cc1fbf59ef3d1bf9ffd28d3357d3f7/analysis/1511168707/ …\n"
"Downloads from hxxp://172.106.75.131/temp/amazingdoz.exe d\n"
"https://www.virustotal.com/#/url/2512afa822b8cadbe9e2fa0ecda5ad55d6024b0694fecf265282a63ef88058cf/detection …\n"
"hxxp://www.dk-fyn.dk/ebgate/ri.php\n"
"hxxp://www.fourthtour.it/rus/tour/php.scr\n"
"hxxp://www.foxydance.cz/repository/ri.php\n"
"hxxp://www.sabineclaire.com/girasoli/ri.php,1212 sdfsdfsdsdfsdf\n"
"https://www.reverse.it/sample/b57bd0dec0873bea8e47a16e1da41aafa817ae11d536c90cb7aec6d6686b686e?environmentId=100 …\n"
"hxxp://www.sabineclaire.com/girasoli/ri.php\n"
"sdf.bom\n"
"fasdkj adsflk jasldk fjalskd fjslaskjdf lkaj dsfl")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.