#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((2[0-4]\d|25[0-5]|1\d\d|0\d\d|0\d|\d\d|\d)[\.]){3}(2[0-4]\d|25[0-5]|1\d\d|0\d\d|0\d|\d\d|\d)|(((\w*)://(www)*)\.*((\w*-*\w*)\.)*(\w*)(:\d+)*/*#*(/*)(\w+/)*(\w*\$*\w*\,*\w*\?*=*)*\.*(\w*))|((www\.)*(\w+-*)(\.\w+)+)(:\d+)*/*#*(/*)(\w+/)*(\w*\$*\w*\,*\w*\?*=*)*\.*(\w*)"
Local $sString = "hxxp://securedownload2.duckdns.org:7373/docs/ @JAMESWT_MHT" & @CRLF & _
"abc://www.hhghg.ghgh.jkjkjk.jkjkj.jkjk" & @CRLF & _
"#LokiBot @ hxxp://xupfile.duckdns.org:1133/$59,200.exe " & @CRLF & _
"https://www.reverse.it/sample/529b10d3faaa143c074d0f25ee75c8e9bad7f5982ead482d6c0c19a39d207b68?environmentId=100 …" & @CRLF & _
"1.2.3.4" & @CRLF & _
"www.virustotal.com" & @CRLF & _
"C2: hta.duckdns.org:7373/excel/fre.php" & @CRLF & _
"http://www.virustotal.com/en/file/a94f7db23f64985f22a4250886db0d67e3cc1fbf59ef3d1bf9ffd28d3357d3f7/analysis/1511168707/ …" & @CRLF & _
"Downloads from hxxp://172.106.75.131/temp/amazingdoz.exe d" & @CRLF & _
"https://www.virustotal.com/#/url/2512afa822b8cadbe9e2fa0ecda5ad55d6024b0694fecf265282a63ef88058cf/detection …" & @CRLF & _
"hxxp://www.dk-fyn.dk/ebgate/ri.php" & @CRLF & _
"hxxp://www.fourthtour.it/rus/tour/php.scr" & @CRLF & _
"hxxp://www.foxydance.cz/repository/ri.php" & @CRLF & _
"hxxp://www.sabineclaire.com/girasoli/ri.php,1212 sdfsdfsdsdfsdf" & @CRLF & _
"https://www.reverse.it/sample/b57bd0dec0873bea8e47a16e1da41aafa817ae11d536c90cb7aec6d6686b686e?environmentId=100 …" & @CRLF & _
"hxxp://www.sabineclaire.com/girasoli/ri.php" & @CRLF & _
"sdf.bom" & @CRLF & _
"fasdkj adsflk jasldk fjalskd fjslaskjdf lkaj dsfl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")