import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((2[0-4]\\d|25[0-5]|1\\d\\d|0\\d\\d|0\\d|\\d\\d|\\d)[\\.]){3}(2[0-4]\\d|25[0-5]|1\\d\\d|0\\d\\d|0\\d|\\d\\d|\\d)|(((\\w*)://(www)*)\\.*((\\w*-*\\w*)\\.)*(\\w*)(:\\d+)*/*#*(/*)(\\w+/)*(\\w*\\$*\\w*\\,*\\w*\\?*=*)*\\.*(\\w*))|((www\\.)*(\\w+-*)(\\.\\w+)+)(:\\d+)*/*#*(/*)(\\w+/)*(\\w*\\$*\\w*\\,*\\w*\\?*=*)*\\.*(\\w*)";
final String string = "hxxp://securedownload2.duckdns.org:7373/docs/ @JAMESWT_MHT\n"
+ "abc://www.hhghg.ghgh.jkjkjk.jkjkj.jkjk\n"
+ "#LokiBot @ hxxp://xupfile.duckdns.org:1133/$59,200.exe \n"
+ "https://www.reverse.it/sample/529b10d3faaa143c074d0f25ee75c8e9bad7f5982ead482d6c0c19a39d207b68?environmentId=100 …\n"
+ "1.2.3.4\n"
+ "www.virustotal.com\n"
+ "C2: hta.duckdns.org:7373/excel/fre.php\n"
+ "http://www.virustotal.com/en/file/a94f7db23f64985f22a4250886db0d67e3cc1fbf59ef3d1bf9ffd28d3357d3f7/analysis/1511168707/ …\n"
+ "Downloads from hxxp://172.106.75.131/temp/amazingdoz.exe d\n"
+ "https://www.virustotal.com/#/url/2512afa822b8cadbe9e2fa0ecda5ad55d6024b0694fecf265282a63ef88058cf/detection …\n"
+ "hxxp://www.dk-fyn.dk/ebgate/ri.php\n"
+ "hxxp://www.fourthtour.it/rus/tour/php.scr\n"
+ "hxxp://www.foxydance.cz/repository/ri.php\n"
+ "hxxp://www.sabineclaire.com/girasoli/ri.php,1212 sdfsdfsdsdfsdf\n"
+ "https://www.reverse.it/sample/b57bd0dec0873bea8e47a16e1da41aafa817ae11d536c90cb7aec6d6686b686e?environmentId=100 …\n"
+ "hxxp://www.sabineclaire.com/girasoli/ri.php\n"
+ "sdf.bom\n"
+ "fasdkj adsflk jasldk fjalskd fjslaskjdf lkaj dsfl";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}