re = /^(?!.*?[.]{2})[a-zA-Z0-9][a-zA-Z0-9\-]+\.[a-z0-9\.\-]+$/
str = 'myphotos.22222.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end