using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?[.]{2})[a-zA-Z0-9][a-zA-Z0-9\-]+\.[a-z0-9\.\-]+$";
string input = @"myphotos.22222.com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}