$re = '/^(?!.*?[.]{2})[a-zA-Z0-9][a-zA-Z0-9\-]+\.[a-z0-9\.\-]+$/';
$str = 'myphotos.22222.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);