// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^abc]*").unwrap();
let string = "abcdebcfghijk
^は状況により意味が変わる
[]内にある時は~以外という意味になる
通常は行の先頭を表す
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}