re = /[^abc]*/m
str = 'abcdebcfghijk
^は状況により意味が変わる
[]内にある時は~以外という意味になる
通常は行の先頭を表す
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end