package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^abc]*`)
var str = `abcdebcfghijk
^は状況により意味が変わる
[]内にある時は~以外という意味になる
通常は行の先頭を表す
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}