re = /GTM-[A-Z0-9]+/
str = '<script>(function(a,s,y,n,c,h,i,d,e){s.className+=\' \'+y;h.start=1*new Date;
h.end=i=function(){s.className=s.className.replace(RegExp(\' ?\'+y),\'\')};
(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
})(window,document.documentElement,\'async-hide\',\'dataLayer\',4000,
{\'GTM-Z2GFZPK\':true});</script>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end