#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "GTM-[A-Z0-9]+"
Local $sString = "<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;" & @CRLF & _
" h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};" & @CRLF & _
" (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;" & @CRLF & _
" })(window,document.documentElement,'async-hide','dataLayer',4000," & @CRLF & _
" {'GTM-Z2GFZPK':true});</script>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")