import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "GTM-[A-Z0-9]+";
final String string = "<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;\n"
+ " h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};\n"
+ " (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;\n"
+ " })(window,document.documentElement,'async-hide','dataLayer',4000,\n"
+ " {'GTM-Z2GFZPK':true});</script>\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}