const regex = new RegExp('https://pan\\.baidu\\.com/s/\\w+$', 'gm')
const str = `https://pan.baidu.com/s/1pa7EApPNc8WbgGfQ4nJJJQ
https://pan.baidu.com/s/1hI5tdwvXj8nDTfglFI2QXA
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}