package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://pan\.baidu\.com/s/\w+$`)
var str = `https://pan.baidu.com/s/1pa7EApPNc8WbgGfQ4nJJJQ
https://pan.baidu.com/s/1hI5tdwvXj8nDTfglFI2QXA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}