#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https://pan\.baidu\.com/s/\w+$"
Local $sString = "https://pan.baidu.com/s/1pa7EApPNc8WbgGfQ4nJJJQ" & @CRLF & _
"https://pan.baidu.com/s/1hI5tdwvXj8nDTfglFI2QXA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")